Running the software on Windows

Hi, has anyone tried to run the software from a Windows Subsystem for Linux (WSL) ? I need to run a windows-only laser controller in parallel until we’ve reprogrammed it. Alternatively I’m exploring to test the use of a virtual machine like VMware or VirtualBox

I have set this up on a new windows computer - installed WSL2, ubuntu, and followed the installation steps of SQUID including the cuda setup. So far so good. I only run into an error with the numpy version. The listed version is not compatible with some of the other newer packages (panda and another one). I tried to run the SQUID controller version as simulation but there was an error (actually a numpy object related one!). I intend to try again tomorrow with the actual setup connected and also note down the error and post it here.

Hi @MakerTobey, I knew someone who tried WSL but ended up switching to native Ubuntu. Since python is cross platform and the camera does support windows (SDK download link), you should be able to run the program on Windows directly (although I don’t think any of the Squid users has tried that so far).

Ok I was able to continue and with the newest updates to the set-up documentation, the previous errors are resolved, but I anyway had to set the version of numpy (most recent 1.26.2) manually down to 1.24 . Error:

/usr/lib/python3/dist-packages/scipy/ UserWarning: A NumPy version >=1.17.3 and <1.25.0 is required for this version of SciPy (detected version 1.26.2
  warnings.warn(f"A NumPy version >={np_minversion} and <{np_maxversion}"

And then there were some modules missing: tifffile and torch.

Now I am left with a strange error:

python3 --simulation
load machine-specific configuration
No module named 'control.DaSiamRPN'
custom multipoint script found
QObject::moveToThread: Current thread (0x55d4866fb290) is not the object's thread (0x55d48ca75030).
Cannot move to target thread (0x55d4866fb290)

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "/home/wenzellab/.local/lib/python3.10/site-packages/cv2/qt/plugins" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: xcb, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl.


You’ll need to uninstall opencv-python and install opencv-python-headless